Bug #1044

SMB / Avahi issues

Added by Spiffy - over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Backend
Target version:-
Seen in:

Description

I recently upgraded from 8.0 to 8.0.2 - before the upgrade I did not have this problem.

On Mac OS X, cifs shares shows up 3 times. "Hostname", "freenas" and "Samba Shares on freenas", where Hostname is whatever I set in the smb/cifs config via gui. Before the upgrade, only the "Hostname" showed up.

Another thing is, "Hostname" has the icon of/is identified as a normal PC - while "freenas" and "Samba Shares on freenas" has xserve icons.

Someone on IRC told me, that it might be avahi acting up, so I looked around a bit, and I found the "Samba Shares on freenas" reference in /usr/local/etc/avahi/services/cifs.service, so that might be the place of the error.

History

#1 Updated by Spiffy - over 2 years ago

After a clean reinstall, the issue is the same.

#2 Updated by Garrett Cooper over 2 years ago

Hopefully will fix by the 8.2 RELEASE.

#3 Updated by Garrett Cooper over 2 years ago

  • Resolution set to fixed
  • Status changed from Unscreened to Closed

Fixed in r9142.

#4 Updated by Garrett Cooper over 2 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Investigation

#5 Updated by Garrett Cooper over 2 years ago

See the commit referenced under ticket # 1060. This issue goes deeper than I originally thought, and r9412 starts to address the issue, but doesn't fully resolve it.

Feel free to patch your build with r9412 if you want to get this 'more sane' functionality.

#6 Updated by Garrett Cooper over 2 years ago

  • Resolution set to duplicate
  • Status changed from Investigation to Closed

Marking as a duplicate of ticket # 1060, because ultimately this enhancement / fix should be implemented via that ticket.

Also available in: Atom PDF