Bug #1656

Problem with active directory integration.

Added by Prasad Chandorkar almost 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:GUI
Target version:8.2.0-RELEASE
Seen in:

Description

Hi,

I am trying to add my freenas to windows 2003 domain but after entering all information active directory service is not starting. In /var/log/messages i got following details.

I have checked srv record for my domain & its properly also I have only one domain controller which is my PDC.

details which i put in active directory settings are following

Domain Controller Name: trinesrv00.trine.com
Domain Name (DNS/Realm-Name): trine.com
Host Name (NetBIOS-Name): NAS
Workgroup Name: trine.com

message log:
Jul 17 21:49:05 NAS kernel: lapic4: Forcing LINT1 to edge trigger
Jul 17 21:49:05 NAS kernel: SMP: AP CPU #4 Launched!
Jul 17 21:49:05 NAS kernel: lapic5: Forcing LINT1 to edge trigger
Jul 17 21:49:05 NAS kernel: SMP: AP CPU #5 Launched!
Jul 17 21:49:05 NAS kernel: Trying to mount root from ufs:/dev/ufs/FreeNASs1a
Jul 17 21:49:06 NAS root: /etc/rc: WARNING: failed precmd routine for vmware_guestd
Jul 17 21:49:07 NAS ntpdr1658: ntpd 4.2.4p5-a (1)
Jul 17 21:49:07 NAS kernel: em0: link state changed to UP
Jul 17 21:49:07 NAS kernel: lagg0: link state changed to UP
Jul 17 21:49:08 NAS kernel: em1: link state changed to UP
Jul 17 21:54:46 NAS freenasr2015: Executing: /usr/sbin/service ix-kerberos quietstart
Jul 17 21:54:47 NAS freenasr2015: Executing: /usr/sbin/service ix-nsswitch quietstart
Jul 17 21:54:47 NAS freenas: Generating host.conf.
Jul 17 21:54:47 NAS freenasr2015: Executing: /usr/sbin/service ix-pam quietstart
Jul 17 21:54:47 NAS freenasr2015: Executing: /usr/sbin/service ix-samba quietstart
Jul 17 21:54:47 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit quietstart
Jul 17 21:54:47 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit status
Jul 17 21:54:47 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit status
Jul 17 21:55:33 NAS freenasr2015: Executing: /usr/sbin/service ix-kerberos quietstart
Jul 17 21:55:34 NAS freenasr2015: Executing: /usr/sbin/service ix-nsswitch quietstart
Jul 17 21:55:34 NAS freenas: Generating host.conf.
Jul 17 21:55:34 NAS freenasr2015: Executing: /usr/sbin/service ix-pam quietstart
Jul 17 21:55:34 NAS freenasr2015: Executing: /usr/sbin/service ix-samba quietstart
Jul 17 21:55:34 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit quietstart
Jul 17 21:55:34 NAS freenas: kinit: krb5_get_init_creds: Clock skew too great
Jul 17 21:55:45 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit status
Jul 17 21:55:45 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit status
Jul 17 21:55:45 NAS freenasr2015: Executing: /usr/sbin/service ix-kerberos quietstart
Jul 17 21:55:46 NAS freenasr2015: Executing: /usr/sbin/service ix-nsswitch quietstart
Jul 17 21:55:46 NAS freenas: Generating host.conf.
Jul 17 21:55:46 NAS freenasr2015: Executing: /usr/sbin/service ix-pam quietstart
Jul 17 21:55:46 NAS freenasr2015: Executing: /usr/sbin/service ix-samba quietstart
Jul 17 21:55:46 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit forcestop
Jul 17 21:55:46 NAS freenasr2015: Executing: /usr/sbin/service ix-activedirectory forcestop
Jul 17 21:55:47 NAS freenas: No realm set, are we joined ?
Jul 17 21:55:47 NAS freenasr2015: Executing: /usr/sbin/service winbindd forcestop
Jul 17 21:55:47 NAS freenas: winbindd not running? (check /var/run/samba/winbindd.pid).
Jul 17 21:55:47 NAS freenasr2015: Executing: /usr/sbin/service ix-kinit status
^C
[root@NAS] ~# net ads join
Host is not configured as a member server.
Invalid configuration. Exiting....
Failed to join domain: This operation is only allowed for the PDC of the domain.
[root@NAS] ~# net ads join -S trine.com -U administrator
Host is not configured as a member server.
Invalid configuration. Exiting....
Failed to join domain: This operation is only allowed for the PDC of the domain.
[root@NAS] ~# net ads join -S trinesrv.00.trine.com -U administrator
Host is not configured as a member server.
Invalid configuration. Exiting....
Failed to join domain: This operation is only allowed for the PDC of the domain.
[root@NAS] ~#
change_password* save_rrds.sh* update* updatep2*
save_cfg* save_sshkeys* updatep1*
[root@NAS] ~# host -t srv _ldap._tcp.trine.com
_ldap._tcp.trine.com has SRV record 0 100 389 trinesrv00.trine.com.

History

#1 Updated by paleoN - almost 2 years ago

Fix your time.

Jul 17 21:55:34 NAS freenas: kinit: krb5_get_init_creds: Clock skew too great

#2 Updated by William Grzybowski over 1 year ago

  • Resolution set to worksforme
  • Status changed from Unscreened to Closed

Also available in: Atom PDF