Bug #2409

pbi plugins install missing urls

Added by Ilkka Tengvall about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:ImportantDue date:
Assignee:-% Done:


Target version:-
Seen in: Hardware Configuration:


  1. pbi_browser
    ERROR: No available repos!


According to the above doc the pbi_browser should work out of the box. It requires some repo urls installed first. Documentation should be corrected.


#1 Updated by Ilkka Tengvall about 2 years ago

I fixed this by doing:

wget --no-check-certificate -O pcbsd.rpo "https://github.com/pcbsd/pcbsd/blob/master/src-sh/pbi-manager/repo/pcbsd.rpo?raw=true" 
pbi_addrepo pcbsd.rpo
service pbid stop
service pbid start

naturally, stopping the pbid is not needed, if one didn't start it in the first place...

#2 Updated by Ilkka Tengvall about 2 years ago

root@putka:/mnt/ikraid/ikke/pcbsd # pbi_add --rArch amd64 --repo 001 -r Tmux

07/20 14:10:15 [NOTICE] ServerStat file /root/.pcbsd-aria-stat-amd64 loaded successfully.
[#86130e 0B/0B CN:1 DL:0B]
07/20 14:10:17 [ERROR] CUID#6 - Download aborted. URI=ftp://ftp.pcbsd.org/pub/mirror/sysutils/tmux/9/x64/tmux-1.8-amd64.pbi
Exception: [AbstractCommand.cc:314] errorCode=3 URI=ftp://ftp.pcbsd.org/pub/mirror/sysutils/tmux/9/x64/tmux-1.8-amd64.pbi
-> [FtpNegotiationCommand.cc:299] errorCode=3 Resource not found

07/20 14:10:17 [NOTICE] Download GID#86130effbb797394 not complete: /usr/pbi/.tmux-1.8-amd64.pbi

07/20 14:10:17 [NOTICE] ServerStat file /root/.pcbsd-aria-stat-amd64 saved successfully.

Download Results:
gid |stat|avg speed |path/URI
86130e|ERR | 0B/s|/usr/pbi/.tmux-1.8-amd64.pbi

Status Legend:
(ERR):error occurred.

aria2 will resume download if the transfer is restarted.
If there are any errors, then see the log file. See '-l' option in help/man page for details.
Download Failed:
ERROR: Failed downloading PBIbut that's not enougn, it still requires repo mirror url. And with the above repo it seems to go for the 9 version, not 9.1, and thus fails to download:

#3 Updated by Dru Lavigne about 2 years ago

Thanks for the heads up. This did work as documented when the doc was written, but it looks like somehow the .rpo file was removed from the jail installation since then. I'll fix the doc and will create a separate ticket for the devs to fix the .rpo issue. Marking this ticket as fixed.

#4 Updated by Dru Lavigne about 2 years ago

  • Status changed from Unscreened to Closed
  • Resolution set to fixed

#5 Updated by Dru Lavigne about 2 years ago

See http://support.freenas.org/ticket/2460#comment:1 for the cause and fix.

The docs will indicate that "pkg install pcbsd-utils" should be run before trying to install PBIs.

Also available in: Atom PDF