Bug #296

Firmware update using the GUI fails; using CLI succeeds

Added by lml - almost 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:Garrett Cooper% Done:

0%

Category:Backend
Target version:-
Seen in:

Description

Updating via the WebGUI (System->Settings->Firmware Update) from

[[FreeNAS]]-8.0-RC4-amd64

to

[[FreeNAS]]-8.0-RC5-amd64

using the FreeNAS-8.0-RC5-amd64.GUI_upgrade.xz file fails.

Network activity is visible on the switch for several seconds after pressing the "Update" button and at some point messages such as the following show up in the console:

Apr 12 20:21:10 freenas freenasr1643: Executing: /bin/rm -rf /var/tmp/firmware
Apr 12 20:21:10 freenas freenasr1643: Executing: /bin/mkdir -p /mnt/media/dataset_name/.freenas
Apr 12 20:21:10 freenas freenasr1643: Executing: /usr/sbin/chown www:www /mnt/media/dataset_name/.freenas
Apr 12 20:21:10 freenas freenasr1643: Executing: /bin/ln -s /mnt/media/dataset_name/.freenas /var/tmp/firmware

However, after waiting an additional 30 minutes after the network activity ceases, the server does not reboot, and the version reported remains at FreeNAS-8.0-RC4-amd64.

A forced reboot after the attempted WebGUI firmware update did not improve the situation (it remained at the previous firmware version).

Subsequent search for the FreeNAS server for the FreeNAS-8.0-RC5-amd64.GUI_upgrade.xz file does not reveal it to be under /mnt (or / for that matter).

The sha256sum was verified prior to the update attempts.

My config:

Client OS: Fedora Core 12 (Linux 2.6.32.26-175.fc12.i686.PAE)
Client browser: firefox-3.5.15-1.fc12.i686
Browser add-ons: No Script (but with [[FreeNAS]] server whitelisted); Adblock Plus

Update via CLI by copying the file over NFS mount and then issuing this command:

/usr/bin/xz -cd <path_to_firmware>/FreeNAS-8.0-RC5-amd64.GUI_upgrade.xz | sh /root/update && touch /data/need-update

followed by a manual reboot did succeed in applying the update.

At least 2 other users have run into a similar problem:

(1) reference post at https://sourceforge.net/apps/phpbb/freenas/viewtopic.php?f=99&t=9937 (which is where I got the CLI update method from)

(2) reference the comment section at the bottom of https://sourceforge.net/tracker/index.php?func=detail&aid=3286946&group_id=151951&atid=782616 (this user reported the problem using windows7_64 and firefox 4)

History

#1 Updated by lml - almost 3 years ago

Tried the firmware update via GUI again. This time I was already running FreeNAS-8.0-RELEASE-amd64 and tried the GUI update via FreeNAS-8.0.1-BETA2-amd64-GUI_Upgrade.xz.

I also uninstalled NoScript and Adblock Plus before my attempt. Still using same browser and OS versions.

Still no success with the update via GUI.

#2 Updated by Garrett Cooper over 2 years ago

  • Resolution set to fixed

This issue has been tested and isn't producible with 8.0-RC1 or later. Closing ticket.

#3 Updated by lml - over 2 years ago

This ticket just got marked as "fixed", but the associated comment ("This issue has been tested and isn't producible with 8.0-RC1 or later. Closing ticket.") leads me to question whether the issue was really fixed.

At least 3 users reported experiencing this problem. See the linked-to posts at the end of the original ticket.

Did the issue really get fixed? Or was the decision made that the problem didn't exist because it did not manifest with a given client-OS/client-browser/FreeNAS configuration?

Could someone please specify the exact configuration(s) that was(were) used for testing that lead someone to believe that the problem was fixed?

#4 Updated by Baldur - over 2 years ago

Currently the same problem when trying to update from 8.0.0 release amd64 to 8.0.1 RC1

on commandline, via ssh, i got:
freenas# xz -cd FreeNAS-8.0.1-RC1-amd64-GUI_Upgrade.xz | sh /root/update && touch /data/need-update
dd: /dev/da0s1: short write on character device
dd: /dev/da0s1: end of device
953600+0 records in
3724+1 records out
488194560 bytes transferred in 193.560677 secs (2522178 bytes/sec)

Also available in: Atom PDF