Bug #336

Iscsi target software incorrectly reports all targets as lun:0

Added by Arvid Stanson almost 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Backend
Target version:-
Seen in:

Description

the iscsi target software available on freenas reports all targets as lun=0 instead of a guid value. this effectively means that you cannot use freenas with multipathing capable initiators due to the fact that if you connect more than 1 iscsi target to the initiator it believes it to be a disabled multi-path.

to reproduce the bug install any multipath capable initiator. i prefer vmware as it is very standards compliant. build 2 freenas storage boxes. connect an iscsi target from the first box. then create a target on the 2nd freenas box and attempt to attach it. the result will be that the 2nd connection will have a "dead" status because the luns are identical even if you make them different sizes.

History

#1 Updated by Arvid Stanson almost 3 years ago

I made a mistake upon review the issue is that all iscsi targets are sequentially numbered the same way
IE freebsd_iscsi_disk++100001 ... 10002 etc. the same occurs with every iscsi target created on a different system. not unique and thus the conflict.

#2 Updated by Josh Paetzel almost 3 years ago

  • Resolution set to fixed
  • Status changed from Unscreened to Closed

The GUI in 8.0.1-BETA3 now allows you to set a unique ID for targets. The default is generated from the system's MAC address.

#3 Updated by Arvid Stanson over 2 years ago

Replying to [comment:2 jpaetzel]:

The GUI in 8.0.1-BETA3 now allows you to set a unique ID for targets. The default is generated from the system's MAC address.

you guys rock!

Also available in: Atom PDF