Bug #368

FreeNAS 8 Freezing On VMware ESXi 4.1

Added by Michael J almost 3 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:UrgentDue date:
Assignee:-% Done:

0%

Category:Backend
Target version:8.0-RELEASE
Seen in:

Description

I have a FreeNAS 8 VM set up on my home VMware ESXi 4.1 server. The VM host is a Dell PowerEdge 2850 with a PERC raid card, 3 drives in RAID5 configuration.

Through VMware, I present a single disk to FreeNAS 8. The volume is then formatted with ZFS. I enabled CIFS and am accessing the volume over the network from a Windows 7 x64 desktop.

I noticed pretty quickly that if I left a torrent seeding over night, I'd wake up to FreeNAS having frozen. When this happens, I cannot ping, ssh, or http to the FreeNAS instance. If I hop on VMware and access the FreeNAS console, I see the 1-9 menu options. No matter what option I choose, after I press enter, nothing happens. If I do not have any constant data access to the FreeNAS volume, it stays up fine for days.

After forcing a reboot, I see the obvious "volume was not uncleanly mounted" message at boot. Log files in /var/log say nothing about any errors.

I did notice that in VMware, the FreeNAS VM's VMware tools status is listed as "unmanaged". Meaning VMWare tools is installed, but VMware isn't managing the updating of it. I cannot update VMware tools to the newest version because perl isn't packaged with FreeNAS.

I'm not sure if it's possibly an issue with FreeNAS and the SCSI drivers in VMware tools or not; maybe that's just a red herring to the actual problem.

History

#1 Updated by Josh Paetzel almost 3 years ago

How much RAM is allocated to the FreeNAS VM? Is it an amd64 image or i386?

We do most of the FreeNAS development on vmware ESXi 4.1 boxes as well as a big chunk of testing and haven't encountered issues with it freezing.

What other VMs are running?

VMware doesn't support FreeBSD as a guest so the lack of perl isn't the only issue to upgrading the vmware tools via vsphere. The image has the latest version of open-vm-tools in the FreeBSD ports tree.

#2 Updated by Michael J almost 3 years ago

VM Host is a Dell PowerEdge 2850. 2x Single Core Intel Processors; 4GB RAM; 3x 146GB 10kRPM disks in RAID5.

FreeNAS VM is the i386 image, has been given 768MB RAM, and one vCPU. Only other VM running is a single vCPU and 2GB RAM linux VM. Both are sitting there nearly idle, so I'm not oversubscribed on CPU or RAM.

#3 Updated by Josh Paetzel almost 3 years ago

ZFS was designed by Sun to run on amd64 architecture. Their initial offering had 64 GB of RAM. FreeBSD with 768 MB of RAM on i386 is not a good platform for ZFS. Deadlocks and kernel panics will be hard to avoid. I'd recommend an amd64 install with 2 GB of RAM (and even that will limit the performance) or switching to UFS.

#4 Updated by mikel - almost 3 years ago

I am also experiencing this problem.

System is a HP ProLiant Microserver. I have allocated 4GB of RAM to the VM and I am accessing it via NFS. Installed the x64 version.

There is no output to the logs or console. I am forced to reset the VM to get it going again. I can force it to crash within minutes reliably.

System will stay up reliably if I do not access it. Without a volume I had it running for days.

FreeNAS 8 is something I just cannot use in this state. This is a critical issue.

#5 Updated by jaeger - almost 3 years ago

I am facing the same issue. I have HP Proliant Microserver N36L running with ESXI 4.1. All is running fine except Freenas 8 which crashes when uploading large files. I am using 4 GB Ram and the AMD64 install. I got it working when only one cpu is used but this limits the speed of freenas....

Please fix this issue, if i can help, please write how to support you.

#6 Updated by ceckerle - almost 3 years ago

I had the same freezing problem after extensive CIFS activity. Before the freezes all memory indicators under System -> Reporting decreased which is exactly whats described at http://lists.freebsd.org/pipermail/freebsd-fs/2011-February/010647.html

Since disabling sendfile support as described in that thread it did not happen again.

#7 Updated by Josh Paetzel almost 3 years ago

  • Resolution set to fixed
  • Status changed from Unscreened to Closed

FreeNAS-8.0.1-BETA3 has a sendfile fix for FreeBSD backported from STABLE in to it. This should resolve these issues.

Also available in: Atom PDF