Project

General

Profile

Bug #4123

Sysctls not set correctly

Added by Lars Neumann over 3 years ago. Updated over 3 years ago.

Status:
Closed: Behaves correctly
Priority:
No priority
Category:
GUI (Django/Legacy)
Target version:
-
Start date:
02/05/2014
Due date:
% Done:

0%

Seen in:
Hardware Configuration:
Blanket Approval:
No
ChangeLog Required:
No
Needs QA:
Yes
QA Status:
Not Tested

Description

Hi,

I have two sysctls set in the GUI that are not set correctly. This behaviour has been observed on all 9.x releases.

sysctl -a | grep cx_low
<118>hw.acpi.cpu.cx_lowest: C1 -> C2
hw.acpi.cpu.cx_lowest: C1
dev.cpu.0.cx_lowest: C1
dev.cpu.1.cx_lowest: C1
dev.cpu.2.cx_lowest: C1
dev.cpu.3.cx_lowest: C1

The same result with the other setting I made. There is always a prefix of <118>.

Regards,

Lars

screenshot.JPG View - GUI screenshot (29.5 KB) Lars Neumann, 02/07/2014 08:28 AM

419

Related issues

Related to FreeNAS - Bug #6250: sysctl is not set Closed: Duplicate 10/02/2014

History

#1 Updated by Lars Neumann over 3 years ago

Before you ask - I deleted the sysctl settings in the GUI and added them again - no change.

#2 Updated by Anonymous over 3 years ago

Hello Lars,

The <118> line is the grep capturing a line from the kernel or console message buffer which is output with 'sysctl -a' (kern.msgbuf, actually).

Can you paste the output of this command, please:

sysctl dev.cpu.0.cx_supported

This will tell us which C-states are supported on your CPU based on the current system & BIOS configuration.

#3 Updated by Lars Neumann over 3 years ago

Hello Doug,

the output is:

dev.cpu.0.cx_supported: C1/1/1 C2/2/148

dmesg output for the CPU

CPU: Intel(R) Core(TM) i3-4330T CPU @ 3.00GHz (2999.19-MHz K8-class CPU)
Origin = "GenuineIntel" Id = 0x306c3 Family = 0x6 Model = 0x3c Stepping = 3
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
Features2=0x7fdafbbf<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,<b11>,FMA,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,MOVBE,POPCNT,TSCDLT,AESNI,XSAVE,OSXSAVE,AVX,F16C,RDRAND>
AMD Features=0x2c100800<SYSCALL,NX,Page1GB,RDTSCP,LM>
AMD Features2=0x21<LAHF,ABM>
Standard Extended Features=0x27ab<GSFSBASE,TSCADJ,SMEP,ENHMOVSB,INVPCID>
TSC: P-state invariant, performance statistics

All C-States are enabled in the BIOS, I am wondering why C3 does not show up at least.
I can set both sysctl in the console and they work just fine, it just does not work from the GUI:

[root@freenas] ~# sysctl hw.acpi.cpu.cx_lowest=C2
hw.acpi.cpu.cx_lowest: C1 -> C2

[root@freenas] ~# sysctl -a | grep cx_lowest
<118>hw.acpi.cpu.cx_lowest: C1 -> C2
hw.acpi.cpu.cx_lowest: C2
dev.cpu.0.cx_lowest: C2
dev.cpu.1.cx_lowest: C2
dev.cpu.2.cx_lowest: C2
dev.cpu.3.cx_lowest: C2

#4 Updated by Anonymous over 3 years ago

Can you show us a screenshot of how they are set "in the GUI"? There is no option to set the ACPI C-state mode explicitly.

Thanks!

#5 Updated by Jordan Hubbard over 3 years ago

  • Assignee set to William Grzybowski
  • Target version set to 72

#6 Updated by Lars Neumann over 3 years ago

419

Sure...

The problem is not the C-State (well, sort of - I would like to see a higher state) but that sysctls settings in the GUI do not seem be set properly. The same setting works fine on the command line.

See the output (of sysctl -a after reboot) from my initial posting:
<118>hw.acpi.cpu.cx_lowest: C1 -> C2
hw.acpi.cpu.cx_lowest: C1

#7 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to Screened

hw.acpi.cpu.cx_lowest is a special case, there is another rc.d script that messes with this sysctl.
Other sysctls should work just fine.

#8 Updated by Lars Neumann over 3 years ago

So I found the case that doesn't work :-)

Thanks for investigating.

#9 Updated by William Grzybowski over 3 years ago

  • Target version deleted (72)
  • Status changed from Screened to Closed: Behaves correctly

hw.acpi.cpu.cx_lowest is a special case as far as I can tell, due to rc.conf and powerd interferences.

I am marking this as a behaves correctly, feel free to reopen if you disagree.

Thanks.

#10 Updated by William Grzybowski about 3 years ago

  • Related to Bug #6250: sysctl is not set added

Also available in: Atom PDF