Bug #4836

Can't list snapshots in GUI.

Added by Mattew Panz 12 months ago. Updated 11 months ago.

Status:ResolvedStart date:04/18/2014
Priority:NormalDue date:
Assignee:Josh Paetzel% Done:

0%

Category:GUI
Target version:9.2.1.5-RELEASE
Seen in:9.2.1.4-RELEASE Doc Needed:

Description

Listing snapshots via GUI I get:

Sorry, an error occurred

(see attached screenshot)

snaplist.png (240 KB) Josh Paetzel, 04/19/2014 07:36 AM

759

Related issues

Duplicated by FreeNAS - Bug #4842: Zfs snapshots not visible in UI Duplicate 04/19/2014

Associated revisions

Revision 126f828e
Added by Josh Paetzel 12 months ago

Fix error that slipped though.

Ticket: #4836

Revision df2b32c6
Added by Josh Paetzel 12 months ago

Fix error that slipped though.

Ticket: #4836

History

#1 Updated by Josh Paetzel 12 months ago

  • Status changed from Unscreened to Screened
  • Assignee set to Josh Paetzel

This sounds like browser cache issues. Can you try it from private browsing mode? If it works there clearing your browser cache should fix it.

If it doesn't work in that case we'll need to know your browser version and OS version.

#2 Updated by Mattew Panz 12 months ago

It doesn't work: I tried clearing the cache in

Firefox 28.0 (Win 7 64 bit);

IE 11.0.9600 (Win 7 64 bit);

iOS v. 7.1 on iPad.

Interesting thing: if I go to shell and

zfs list -t snapshot

all my periodic snapshots are there, but they don't show as Previous Versions in Windows only from the date I upgraded from FreeNAS v. 9.2.1.3 to 9.2.1.4

for example: I updated on the 18th of April; Previous Versions show last available version dated 17th.

#3 Updated by Jordan Hubbard 12 months ago

Sounds like this is forking into two different issues - let's try to keep them separate.

1. Can anyone reproduce the GUI problem with a browser that's !Firefox? This seems to be a common theme with a lot of our "UI bugs" lately.

2. Let's break the "Previous versions" in Windows issue into another bug.

#4 Updated by Helge Simonsen 12 months ago

I'm getting the "Sorry an error occured" in GUI myself on three different systems against two different FreeNAS 9.2.1.4 systems.

Tried Firefox, Opera, IE and Chrome on Win 7 and Win2008R2. Same error nommatter.

#5 Updated by Josh Paetzel 12 months ago

  • File snaplist.png added
  • Category set to GUI
  • Target version set to 79

I really do not like "Works on my machine" responses from developers, however in this case it works on my machine! Screenshot attached of GUI showing snapshots on 9.2.1.4 from chrome in w28r2.

Can you try Firebug in firefox and see if you can get at the actual error that is occurring?

Also can someone who is having an issue with previous versions please open a separate ticket for that?

#6 Updated by Mattew Panz 12 months ago

Hi Josh, I've just reverted my machine to FreeNAS 9.2.1.3 and snapshots reappeared :)

For me it is not related to the browser.

#7 Updated by Helge Simonsen 12 months ago

Same here. I reverted to 9.2.1.3 and all is well again.

Back to 9.2.1.4 and i get the error in GUI listing snapshots again.
Tested "all" browsers on one Win2008R2, two Win7. Error all over.

Tried safari on my iPhone and get a error there too, so it's not windows related.

#8 Updated by Josh Paetzel 12 months ago

Ok, I am able to reproduce this. It requires a replication task being enabled to trigger, but if there is a replication task it's 100% reproducible.

Working on a fix.

#9 Updated by Josh Paetzel 12 months ago

  • Status changed from Screened to Resolved
  • Target version changed from 79 to 92

#10 Updated by Eric Langley 12 months ago

I have the same issue, upgraded from 9.2.0 to 9.2.1.4. Snapshots for a ZFS Dataset that has snapshots enabled and a replication job setup will not display.

#11 Updated by Eric Langley 12 months ago

FWIW, I do have 9.2.1.4 installations snapshot displays work properly with replication enabled, however they were fresh installations, not upgrades.

#12 Updated by Jordan Hubbard 11 months ago

  • Target version changed from 92 to 9.2.1.5-RELEASE

Also available in: Atom PDF