Project

General

Profile

Bug #9938

FreeNAS Mini SATA ports

Added by Marius Busch over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Important
Category:
FreeBSD / Drivers / ZFS
Target version:
-
Start date:
05/23/2015
Due date:
% Done:

0%

Seen in:
Hardware Configuration:
Blanket Approval:
No
ChangeLog Required:
No
Needs QA:
Yes
QA Status:
Not Tested

Description

This is at least the third FreeNAS Mini user I witnessed who complained about log entries showing disconnecting drives. All those affected drives were connected to the white Marvell SATA ports on the right-hand side of the board.

Please make sure the FreeNAS Mini is shipped with HDD bays connected to the blue Intel SATA ports and the DOM plugged into one of the white Intel SATA ports right next to it. (actually the blue Intel 3Gbps SATA ports are faster than the Marvell 6Gbps ports.)

setup_dmesg.txt View - dmesg (12.4 KB) Alison Chaiken, 05/23/2015 07:16 PM

var-log-messages.txt View - /var/log/messages from the unit. (203 KB) Alison Chaiken, 05/23/2015 07:18 PM

History

#1 Updated by Jordan Hubbard over 2 years ago

Can we get some attached photos of the mis-wired system? It will help to show the production folks.

#2 Updated by Jordan Hubbard over 2 years ago

Ah, someone has already made some pictures and posted them here: https://www.flickr.com/photos/99725460@N00/sets/72157652932466288
Still, if we have more pictures, still attach them to this ticket please.

#3 Updated by Alison Chaiken over 2 years ago

I'm the one who reported the problem on #freenas at Freenode. I just created an account for myself.

#4 Updated by Alison Chaiken over 2 years ago

Initial cabling:
White Marvell connectors near case front:
SATAII_M3 Dangling-end SATA cable
SATAII_M2 Dangling-end SATA cable
SATAII_M1 Apacer DOM
SATAII_M0 unpopulated
SATA3_M1 blue SATA cable -- plugged in
SATA3_M0 blue SATA cable -- plugged in

Near case rear:
Blue Intel connectors:
SATA_5 unpopulated
SATA_4 unpopulated
SATA_3 unpopulated
SATA_2 unpopulated

White connectors:
SATA_1 blue SATA cable -- plugged in
SATA_0 blue SATA cable -- plugged in

#5 Updated by Alison Chaiken over 2 years ago

#7 Updated by Alison Chaiken over 2 years ago

I'll plan to take the unit to iX Systems in SJ for service, as there's not enough clearance around the SATA connectors to unplug them without removing the mobo from the case, which I'd rather not do.

#8 Updated by Alison Chaiken over 2 years ago

I decided to recable the system as unanimously suggested by ruffians hanging out in #freenas.

After I recabled the unit, the drive order from the top to the bottom of the case is the same as from the left to the right of the SATA connectors as viewed from the case rear. In other words, after recabling,

Front label Mobo connector ================================================================
0 SATA_2
1 SATA_3
2 SATA_4
3 SATA_5

The new dmesg reflects the fact that the drives have been reordered, and now ada2 does not report errors in /var/log/messages at boot.

Before, repeated many times:
Mar 27 09:43:59 freenas kernel: ZFS WARNING: Unable to attach to ada2.

After:
May 25 10:50:28 beastie GEOM_ELI: Device ada2p1.eli created.

(The difference in dates is just due to ntp running in-between.)

I left the DOM in its original position since there is not enough clearance to the case rear for it to fit into one of the SATA connectors near where the HDD are now plugged in. There are now new photos at the Flickr link above.

I guess the system is now working as intended, although I'd be happy to hear any further advice.

I suppose I have completely voided my warranty, although it's not my fault if the unit was originally assembled improperly. The whole point of purchasing a pre-installed box was to avoid the tasks I ended up doing yesterday anyway!

#9 Updated by Jordan Hubbard over 2 years ago

  • Status changed from Unscreened to Resolved

Issue has been raised with production. More than that, cannot be done from the freenas bug tracker.

#10 Updated by Alison Chaiken over 2 years ago

Serial number of my system is A1-39468. I have my warranty is not voided given that, essentially, I performed the final assembly myself.

Also available in: Atom PDF